AD Manager Plus

Some packages are not compatible with UAP

You may get following error messages when trying to install  some Azure packages in UWP application:

Microsoft.Data.OData 5.7.0 is not compatible with UAP,Version=v10.0.
System.Spatial 5.7.0 is not compatible with UAP,Version=v10.0.
Microsoft.Data.Edm 5.7.0 is not compatible with UAP,Version=v10.0.
Some packages are not compatible with UAP,Version=v10.0
Microsoft.Xaml.Behaviors.Uwp.Managed 1.1.0 is not compatible with UAP,Version=v10.0

Solution : As per this article on stack overflow , you need to follow these steps:

  • download the latest version of nuget.exe from https://dist.nuget.org/index.html
  • list the local cache with this command: nuget locals all -list
  • clear all caches with this command: nuget locals all -clear

Still if you are having the same issue please refer to this ink : https://github.com/Microsoft/vsts-agent/issues/435

Popular Posts